安装Ruby 安装CocoaPods图文教程(高清无码多图)

Home / iOS MrLee 2015-1-25 2621

在我们做iOS开发的过程中,经常会用到一些大牛的第三方框架,但是手动管理比较麻烦耗时,所以在2011年8月,CocoaPods应运而生,经过这么多年发展,现在已经成为iOS开发事实上的依赖管理标准工具.好处不再多说,自己百度去....我把自己安装的过程贴出来(作为菜鸟我之前也没用过),希望对一些新手开发者(包括自己)有些帮助.
1 安装ruby环境: 以下代码区域,带有$的表示需要在终端敲入,但是不要带$
①  $ curl -L https://get.rvm.io | bash -s stable
键入这句之后,效果如下:

1


在看到thank you的时候我感觉成功了,哈哈,这部如果网络OK还是很快就好的.
② 载入RVM环境,如果是新开的终端就不需要了,会自动载入
载入代码:$ source ~/.rvm/scripts/rvm
然后检查一下,是否安装正确
检查代码: rvm -v
如果显示: rvm 1.22.17 (stable) by Wayne E. Seguin , Michal Papis

[https://rvm.io/] 说明成功;
效果图如下:
2



③ 用RVM安装ruby环境
安装代码: $ rvm install 2.0.0
PS:这步就比较坑了,天杀的太慢了..吐槽一下我们大天朝的网络
直接看图:

3


图中1 表示电脑中没有安装Homebrew,这玩意是啥,小弟不清楚,哈哈,不过下面的英文还是看得懂的,我不打算更换路径,所以直接回车键
图中2 表示开始安装,但是需要再次回车
图中3 要输入一次密码
图中4 就是蛋疼的地方,我家里12M光钎下载速度最快10K/S,最慢2.3K/S ,没喝酒,但是我醉了.没办法,等待吧..(趁机抽根烟去...)
经过了整整五六个小时,貌似终于安装完毕咯!上图

4


④ 然后执行一下 $ rvm 2.0.0 --default 将指定版本的Ruby设置为系统默认版本,当然也可以用其他版本,但是前提是有用rvm install安装过那个版本,然后利用下面代码测试是否正确设置了.

ruby -v  结果是:ruby 2.0.0p598 (2014-11-13 revision 48408) [x86_64-darwin14.0.0]

gem -v  结果是:2.4.5

这步结束,ruby安装完毕,然后我们开始安装CocoaPods

⑤ 本来应该是sudo gem install cocoapods,但是由于cocoapods.org被我们大天朝给墙了,所以现在好的方法是利用淘宝的Ruby镜像,按照下面的顺序在终端中依次敲入命令:

$ gem sources --remove https://rubygems.org/ 这里一定要注意是--两个横杠,而不是一个,否则会失败,并且无法安装cocopods

在第一步应该显示https://rubygems.org/ removed from sources

然后键入命令:$ gem sources -a http://ruby.taobao.org/

显示结果为http://ruby.taobao.org/ added to sources

这时我们测试一下:$ gem sources -l

5



这样结果说明我们已经更改淘宝镜像成功.
⑥ 下面开始安装cocoapods,键入下面的命令:

$ sudo gem install cocoapods,这部十秒钟不到就搞定了,页面太长就不截图了,最后一点给大家截出来

6

至此,我们的cocoapods就安装完毕,后面我会抽时间把如何使用cocoapods也贴出来,等我研究下..嘿嘿

本文链接:https://www.it72.com/927.htm

推荐阅读
最新回复 (0)
返回
站点信息
  • 文章
    2237
  • 用户
    1311
  • 访客
    7881704
每日一句